38 lines
1.7 KiB
Nix
38 lines
1.7 KiB
Nix
{
|
|
lib,
|
|
inputs,
|
|
config,
|
|
...
|
|
}: {
|
|
imports = [
|
|
inputs.thymis.nixosModules.thymis-controller
|
|
];
|
|
|
|
services.thymis-controller = {
|
|
enable = true;
|
|
system-binfmt-aarch64-enable = true; # enables emulation of aarch64 binaries, default is true on x86_64, needed for building aarch64 images on x86_64
|
|
system-binfmt-x86_64-enable = false; # enables emulation of x86_64 binaries, default is false
|
|
repo-path = "/var/lib/thymis/repository"; # directory where the controller will store the repository holding the project
|
|
database-url = "sqlite:////var/lib/thymis/thymis.sqlite"; # URL of the database
|
|
base-url = "https://wallabag.vulpecula.zone/"; # base URL of the controller, how it will be accessed from the outside
|
|
auth-basic = true; # whether to enable authentication using a basic username/password
|
|
auth-basic-username = "admin"; # username for basic authentication
|
|
auth-basic-password-file = "/var/lib/thymis/auth-basic-password"; # file containing the password for basic authentication
|
|
# content will be automatically generated if it does not exist
|
|
listen-host = "127.0.0.1"; # host on which the controller listens for incoming connections
|
|
listen-port = 8000; # port on which the controller listens for incoming connections
|
|
nginx-vhost-enable = true; # whether to enable the Nginx virtual host
|
|
nginx-vhost-name = "wallabag.vulpecula.zone"; # name of the Nginx virtual host
|
|
};
|
|
|
|
# Configure the Nginx virtual host
|
|
services.nginx = {
|
|
virtualHosts."thymis.vulpecula.zone" = {
|
|
# serverName = "wallabag.vulpecula.zone";
|
|
# locations."/".proxyPass = "http://localhost:${toString config.services.thymis-controller.listen-port}";
|
|
enableACME = true;
|
|
forceSSL = true;
|
|
};
|
|
};
|
|
}
|