22 lines
548 B
Nix
22 lines
548 B
Nix
{
|
|
config,
|
|
pkgs,
|
|
...
|
|
}: {
|
|
services.nginx.virtualHosts."nextcloud.vulpecula.zone" = {
|
|
addSSL = true;
|
|
enableACME = true;
|
|
# locations."/".proxyPass = "http://localhost:${toString config.services.forgejo.settings.server.HTTP_PORT}";
|
|
};
|
|
|
|
environment.etc."nextcloud-admin-pass".text = "Devdevdev10!";
|
|
services.nextcloud = {
|
|
enable = true;
|
|
package = pkgs.nextcloud30;
|
|
hostName = "nextcloud.vulpecula.zone";
|
|
config.adminpassFile = "/etc/nextcloud-admin-pass";
|
|
config.dbtype = "sqlite";
|
|
https = true;
|
|
};
|
|
}
|