53 lines
1.8 KiB
Nix
53 lines
1.8 KiB
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{
|
||
config,
|
||
lib,
|
||
pkgs,
|
||
modulesPath,
|
||
...
|
||
}: {
|
||
imports = [
|
||
(modulesPath + "/installer/scan/not-detected.nix")
|
||
];
|
||
|
||
boot.initrd.availableKernelModules = ["xhci_pci" "ehci_pci" "ahci" "usbhid" "uas" "sd_mod"];
|
||
boot.initrd.kernelModules = [];
|
||
boot.kernelModules = ["kvm-intel"];
|
||
boot.extraModulePackages = [];
|
||
|
||
fileSystems."/" = {
|
||
device = "/dev/disk/by-uuid/223771ac-0c08-4b1e-bfbd-0e6a35868732";
|
||
fsType = "btrfs";
|
||
options = ["subvol=@" "compress=zstd:5" "discard=async"];
|
||
};
|
||
|
||
boot.initrd.luks.devices."luks-9977dbf8-b4f4-44cd-8246-5c9c4e1f9084".device = "/dev/disk/by-uuid/9977dbf8-b4f4-44cd-8246-5c9c4e1f9084";
|
||
|
||
fileSystems."/boot" = {
|
||
device = "/dev/disk/by-uuid/1EC1-D46C";
|
||
fsType = "vfat";
|
||
};
|
||
|
||
fileSystems."/data" = {
|
||
device = "/dev/disk/by-uuid/5967ac1b-9624-4028-9b0b-4d270466ddf1";
|
||
fsType = "btrfs";
|
||
};
|
||
|
||
boot.initrd.luks.devices."data".device = "/dev/disk/by-uuid/6b8d73d9-a9ac-43f6-9883-f902135f8b8c";
|
||
|
||
swapDevices = [];
|
||
|
||
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
||
# (the default) this is the recommended approach. When using systemd-networkd it's
|
||
# still possible to use this option, but it's recommended to use it in conjunction
|
||
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
||
networking.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
|
||
# networking.interfaces.tailscale0.useDHCP = lib.mkDefault true;
|
||
|
||
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
||
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|